CVE-2026-111497 Affecting drain-cleaner package, versions <1.8.0-r2


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

Social Trends
Exploit Maturity
Attacked
EPSS
82.64% (100th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-DRAINCLEANER-21757268
  • published28 Oct 2026
  • disclosed22 Oct 2026

Introduced: 22 Oct 2026

NewCVE-2026-111497  (opens in a new tab)

How to fix?

Upgrade Chainguard drain-cleaner to version 1.8.0-r2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream drain-cleaner package and not the drain-cleaner package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream.

Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.

References

CVSS Base Scores

version 3.1