Improper Cross-boundary Removal of Sensitive Data Affecting elasticsearch-8.17 package, versions <8.17.10-r13


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.51% (42nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-ELASTICSEARCH817-15255865
  • published11 Feb 2026
  • disclosed4 Mar 2025

Introduced: 4 Mar 2025

CVE-2025-27221  (opens in a new tab)
CWE-212  (opens in a new tab)

How to fix?

Upgrade Chainguard elasticsearch-8.17 to version 8.17.10-r13 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream elasticsearch-8.17 package and not the elasticsearch-8.17 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

In the URI gem before 1.0.3 for Ruby, the URI handling methods (URI.join, URI#merge, URI#+) have an inadvertent leakage of authentication credentials because userinfo is retained even after changing the host.

CVSS Base Scores

version 3.1