Use of Uninitialized Resource Affecting ffmpeg-cuda-fips-8.1 package, versions <8.1.3-r0


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.18% (7th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-FFMPEGCUDAFIPS81-21460669
  • published23 Oct 2026
  • disclosed6 Aug 2026

Introduced: 6 Aug 2026

CVE-2026-70629  (opens in a new tab)
CWE-908  (opens in a new tab)

How to fix?

Upgrade Chainguard ffmpeg-cuda-fips-8.1 to version 8.1.3-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ffmpeg-cuda-fips-8.1 package and not the ffmpeg-cuda-fips-8.1 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

FFmpeg versions from 3.0 up to, but not including, 9.0 contain an uninitialized heap memory read vulnerability in the native RSCC decoder (libavcodec/rscc.c) that allows attackers to disclose heap memory contents by supplying a crafted video file with a compressed tile that decompresses fewer bytes than the declared tile geometry requires. When rscc_decode_frame() calls av_image_copy_plane() without validating the decompressed byte count against the tile dimensions, the unwritten suffix of the persistent intermediate buffer ctx->inflated_buf is copied into the decoded frame, potentially exposing data from prior heap allocations or previous decoded frames in persistent decoding services.

CVSS Base Scores

version 3.1