Access of Resource Using Incompatible Type ('Type Confusion') Affecting flux-fips-2.5 package, versions <2.5.1-r20


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.26% (17th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-FLUXFIPS25-16800091
  • published23 May 2026
  • disclosed8 Apr 2026

Introduced: 8 Apr 2026

CVE-2026-27144  (opens in a new tab)
CWE-843  (opens in a new tab)

How to fix?

Upgrade Chainguard flux-fips-2.5 to version 2.5.1-r20 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream flux-fips-2.5 package and not the flux-fips-2.5 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

The compiler is meant to unwrap pointers which are the operands of a memory move; a no-op interface conversion prevented the compiler from making the correct determination about non-overlapping moves, potentially leading to memory corruption at runtime.

CVSS Base Scores

version 3.1