Improper Access Control Affecting freeipa package, versions <4.12.5-r0


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.61% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-FREEIPA-13775784
  • published30 Oct 2025
  • disclosed7 Sept 2016

Introduced: 7 Sep 2016

CVE-2016-5404  (opens in a new tab)
CWE-284  (opens in a new tab)

How to fix?

Upgrade Chainguard freeipa to version 4.12.5-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream freeipa package and not the freeipa package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

The cert_revoke command in FreeIPA does not check for the "revoke certificate" permission, which allows remote authenticated users to revoke arbitrary certificates by leveraging the "retrieve certificate" permission.