Out-of-Bounds Affecting gdal-3.8 package, versions <3.8.5-r16


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.22% (13th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-GDAL38-17238998
  • published8 Jun 2026
  • disclosed7 May 2026

Introduced: 7 May 2026

CVE-2026-8087  (opens in a new tab)
CWE-119  (opens in a new tab)
CWE-122  (opens in a new tab)

How to fix?

Upgrade Chainguard gdal-3.8 to version 3.8.5-r16 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gdal-3.8 package and not the gdal-3.8 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

A security flaw has been discovered in OSGeo gdal up to 3.13.0dev-4. Impacted is the function GDnentries of the file frmts/hdf4/hdf-eos/GDapi.c. Performing a manipulation of the argument DataFieldName results in heap-based buffer overflow. The attack must be initiated from a local position. The exploit has been released to the public and may be used for attacks. Upgrading to version 3.13.0RC1 is recommended to address this issue. The patch is named 184f77dbcc74118c062c05e464c88161d3c37b9b. You should upgrade the affected component.

CVSS Base Scores

version 3.1