CVE-2020-11971 Affecting geoserver-2.28 package, versions <2.28.2-r3


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
13.96% (97th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-GEOSERVER228-15702507
  • published20 Mar 2026
  • disclosed14 May 2020

Introduced: 14 May 2020

CVE-2020-11971  (opens in a new tab)

How to fix?

Upgrade Chainguard geoserver-2.28 to version 2.28.2-r3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream geoserver-2.28 package and not the geoserver-2.28 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

Apache Camel's JMX is vulnerable to Rebind Flaw. Apache Camel 2.22.x, 2.23.x, 2.24.x, 2.25.x, 3.0.0 up to 3.1.0 is affected. Users should upgrade to 3.2.0.

References

CVSS Base Scores

version 3.1