Improper Neutralization Affecting geoserver-2.28 package, versions <2.28.3-r5


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.89% (60th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-GEOSERVER228-16420121
  • published5 May 2026
  • disclosed21 Jul 2025

Introduced: 21 Jul 2025

CVE-2025-7962  (opens in a new tab)
CWE-147  (opens in a new tab)

How to fix?

Upgrade Chainguard geoserver-2.28 to version 2.28.3-r5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream geoserver-2.28 package and not the geoserver-2.28 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

In Jakarta Mail 2.0.2 it is possible to preform a SMTP Injection by utilizing the \r and \n UTF-8 characters to separate different messages.

CVSS Base Scores

version 3.1