CVE-2025-9287 Affecting gitlab-rails-ce-fips-18.1 package, versions <18.1.6-r17


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.55% (45th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-GITLABRAILSCEFIPS181-17800834
  • published3 Jul 2026
  • disclosed20 Aug 2025

Introduced: 20 Aug 2025

CVE-2025-9287  (opens in a new tab)

How to fix?

Upgrade Chainguard gitlab-rails-ce-fips-18.1 to version 18.1.6-r17 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gitlab-rails-ce-fips-18.1 package and not the gitlab-rails-ce-fips-18.1 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

Improper Input Validation vulnerability in cipher-base allows Input Data Manipulation.This issue affects cipher-base: through 1.0.4.

CVSS Base Scores

version 3.1