Cross-site Scripting (XSS) Affecting grafana-11.4 package, versions <11.4.8-r2


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.5% (85th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-GRAFANA114-9292318
  • published7 Jan 2026
  • disclosed26 Mar 2019

Introduced: 26 Mar 2019

CVE-2019-3826  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Chainguard grafana-11.4 to version 11.4.8-r2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream grafana-11.4 package and not the grafana-11.4 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

A stored, DOM based, cross-site scripting (XSS) flaw was found in Prometheus before version 2.7.1. An attacker could exploit this by convincing an authenticated user to visit a crafted URL on a Prometheus server, allowing for the execution and persistent storage of arbitrary scripts.