Out-of-bounds Write Affecting hadoop-fips-3.3.6 package, versions <3.3.6-r15


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.26% (69th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-HADOOPFIPS336-15256500
  • published11 Feb 2026
  • disclosed13 Dec 2022

Introduced: 13 Dec 2022

CVE-2022-45688  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Chainguard hadoop-fips-3.3.6 to version 3.3.6-r15 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream hadoop-fips-3.3.6 package and not the hadoop-fips-3.3.6 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

A stack overflow in the XML.toJSONObject component of hutool-json v5.8.10 allows attackers to cause a Denial of Service (DoS) via crafted JSON or XML data.

CVSS Base Scores

version 3.1