Out-of-bounds Write Affecting hadoop-fips-3.3.6 package, versions <3.3.6-r21


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.56% (75th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-HADOOPFIPS336-15991034
  • published12 Apr 2026
  • disclosed11 Nov 2022

Introduced: 11 Nov 2022

CVE-2022-41854  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Chainguard hadoop-fips-3.3.6 to version 3.3.6-r21 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream hadoop-fips-3.3.6 package and not the hadoop-fips-3.3.6 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

Those using Snakeyaml to parse untrusted YAML files may be vulnerable to Denial of Service attacks (DOS). If the parser is running on user supplied input, an attacker may supply content that causes the parser to crash by stack overflow. This effect may support a denial of service attack.

CVSS Base Scores

version 3.1