Improper Input Validation Affecting hadoop-fips-3.3.6 package, versions <3.3.6-r21


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
5.22% (93rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-HADOOPFIPS336-15991042
  • published12 Apr 2026
  • disclosed18 Oct 2017

Introduced: 18 Oct 2017

CVE-2015-2156  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Chainguard hadoop-fips-3.3.6 to version 3.3.6-r21 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream hadoop-fips-3.3.6 package and not the hadoop-fips-3.3.6 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

Netty before 3.9.8.Final, 3.10.x before 3.10.3.Final, 4.0.x before 4.0.28.Final, and 4.1.x before 4.1.0.Beta5 and Play Framework 2.x before 2.3.9 might allow remote attackers to bypass the httpOnly flag on cookies and obtain sensitive information by leveraging improper validation of cookie name and value characters.

References