Deserialization of Untrusted Data Affecting hadoop-fips-3.3.6 package, versions <3.3.6-r21


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
11.38% (96th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-HADOOPFIPS336-15991069
  • published12 Apr 2026
  • disclosed23 Aug 2021

Introduced: 23 Aug 2021

CVE-2021-39152  (opens in a new tab)
CWE-502  (opens in a new tab)
CWE-918  (opens in a new tab)

How to fix?

Upgrade Chainguard hadoop-fips-3.3.6 to version 3.3.6-r21 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream hadoop-fips-3.3.6 package and not the hadoop-fips-3.3.6 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

XStream is a simple library to serialize objects to XML and back again. In affected versions this vulnerability may allow a remote attacker to request data from internal resources that are not publicly available only by manipulating the processed input stream with a Java runtime version 14 to 8. No user is affected, who followed the recommendation to setup XStream's security framework with a whitelist limited to the minimal required types. If you rely on XStream's default blacklist of the Security Framework, you will have to use at least version 1.4.18.

CVSS Base Scores

version 3.1