Deserialization of Untrusted Data Affecting hadoop-fips-3.3.6 package, versions <3.3.6-r15


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
5.18% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-HADOOPFIPS336-9509619
  • published22 Mar 2025
  • disclosed1 Oct 2019

Introduced: 1 Oct 2019

CVE-2019-10202  (opens in a new tab)
CWE-502  (opens in a new tab)

How to fix?

Upgrade Chainguard hadoop-fips-3.3.6 to version 3.3.6-r15 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream hadoop-fips-3.3.6 package and not the hadoop-fips-3.3.6 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

A series of deserialization vulnerabilities have been discovered in Codehaus 1.9.x implemented in EAP 7. This CVE fixes CVE-2017-17485, CVE-2017-7525, CVE-2017-15095, CVE-2018-5968, CVE-2018-7489, CVE-2018-1000873, CVE-2019-12086 reported for FasterXML jackson-databind by implementing a whitelist approach that will mitigate these vulnerabilities and future ones alike.

References

CVSS Base Scores

version 3.1