Improper Input Validation Affecting hadoop-fips-3.5 package, versions <3.5.0-r12


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
99.03% (100th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-HADOOPFIPS35-19644307
  • published9 Sept 2026
  • disclosed30 Apr 2014

Introduced: 30 Apr 2014

CVE-2014-0114  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Chainguard hadoop-fips-3.5 to version 3.5.0-r12 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream hadoop-fips-3.5 package and not the hadoop-fips-3.5 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

Apache Commons BeanUtils, as distributed in lib/commons-beanutils-1.8.0.jar in Apache Struts 1.x through 1.3.10 and in other products requiring commons-beanutils through 1.9.2, does not suppress the class property, which allows remote attackers to "manipulate" the ClassLoader and execute arbitrary code via the class parameter, as demonstrated by the passing of this parameter to the getClass method of the ActionForm object in Struts 1.

References

CVSS Base Scores

version 3.1