Incorrect Authorization Affecting haproxy-ingress-fips-0.16 package, versions <0.16.1-r1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.66% (50th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-HAPROXYINGRESSFIPS016-16020357
  • published13 Apr 2026
  • disclosed8 Apr 2026

Introduced: 8 Apr 2026

CVE-2026-27140  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade Chainguard haproxy-ingress-fips-0.16 to version 0.16.1-r1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream haproxy-ingress-fips-0.16 package and not the haproxy-ingress-fips-0.16 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

SWIG file names containing 'cgo' and well-crafted payloads could lead to code smuggling and arbitrary code execution at build time due to trust layer bypass.

CVSS Base Scores

version 3.1