Improper Certificate Validation Affecting httpie package, versions <3.2.3-r0


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.31% (24th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-HTTPIE-7444502
  • published12 Jul 2024
  • disclosed16 Nov 2023

Introduced: 16 Nov 2023

CVE-2023-48052  (opens in a new tab)
CWE-295  (opens in a new tab)

How to fix?

Upgrade Chainguard httpie to version 3.2.3-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream httpie package and not the httpie package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

Missing SSL certificate validation in HTTPie v3.2.2 allows attackers to eavesdrop on communications between the host and server via a man-in-the-middle attack.

CVSS Base Scores

version 3.1