Improper Validation of Specified Type of Input Affecting kyverno-fips-1.12 package, versions <1.12.7-r27


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.77% (56th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-KYVERNOFIPS112-15991664
  • published12 Apr 2026
  • disclosed30 Apr 2025

Introduced: 30 Apr 2025

CVE-2025-46342  (opens in a new tab)
CWE-1287  (opens in a new tab)

How to fix?

Upgrade Chainguard kyverno-fips-1.12 to version 1.12.7-r27 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream kyverno-fips-1.12 package and not the kyverno-fips-1.12 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

Kyverno is a policy engine designed for cloud native platform engineering teams. Prior to versions 1.13.5 and 1.14.0, it may happen that policy rules using namespace selector(s) in their match statements are mistakenly not applied during admission review request processing due to a missing error propagation in function GetNamespaceSelectorsFromNamespaceLister in pkg/utils/engine/labels.go. As a consequence, security-critical mutations and validations are bypassed, potentially allowing attackers with K8s API access to perform malicious operations. This issue has been patched in versions 1.13.5 and 1.14.0.

CVSS Base Scores

version 3.1