Out-of-bounds Read Affecting libssh package, versions <0.12.1-r0


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.49% (40th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-LIBSSH-18741314
  • published13 Aug 2026
  • disclosed21 Jul 2026

Introduced: 21 Jul 2026

CVE-2026-59842  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Chainguard libssh to version 0.12.1-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libssh package and not the libssh package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

A flaw was found in libssh. During server-side GSSAPI key exchange, a client-supplied Curve25519 public key shorter than the expected length is copied without proper length validation, leading to an out-of-bounds heap read. This could allow a remote unauthenticated attacker to disclose small amounts of server memory.

CVSS Base Scores

version 3.1