OS Command Injection Affecting libssh package, versions <0.12.1-r0


Severity

Recommended
0.0
low
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.12% (2nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-LIBSSH-18741727
  • published13 Aug 2026
  • disclosed21 Jul 2026

Introduced: 21 Jul 2026

CVE-2026-59846  (opens in a new tab)
CWE-78  (opens in a new tab)

How to fix?

Upgrade Chainguard libssh to version 0.12.1-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libssh package and not the libssh package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

A flaw was found in libssh. A malicious username expanded through %r in ProxyCommand handling can inject shell metacharacters, exposing environment variables and causing unintended shell behavior.

CVSS Base Scores

version 3.1