Insecure Storage of Sensitive Information Affecting linux-pam package, versions <1.6.0-r0


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.27% (18th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-LINUXPAM-8384050
  • published19 Nov 2024
  • disclosed23 Oct 2024

Introduced: 23 Oct 2024

CVE-2024-10041  (opens in a new tab)
CWE-922  (opens in a new tab)

How to fix?

Upgrade Chainguard linux-pam to version 1.6.0-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream linux-pam package and not the linux-pam package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

A vulnerability was found in PAM. The secret information is stored in memory, where the attacker can trigger the victim program to execute by sending characters to its standard input (stdin). As this occurs, the attacker can train the branch predictor to execute an ROP chain speculatively. This flaw could result in leaked passwords, such as those found in /etc/shadow while performing authentications.

CVSS Base Scores

version 3.1