Use After Free Affecting linux-vmware-6.12 package, versions <6.12.71-r0


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.35% (27th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-LINUXVMWARE612-15044073
  • published21 Jan 2026
  • disclosed10 Sept 2018

Introduced: 10 Sep 2018

CVE-2018-14625  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Chainguard linux-vmware-6.12 to version 6.12.71-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream linux-vmware-6.12 package and not the linux-vmware-6.12 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

A flaw was found in the Linux Kernel where an attacker may be able to have an uncontrolled read to kernel-memory from within a vm guest. A race condition between connect() and close() function may allow an attacker using the AF_VSOCK protocol to gather a 4 byte information leak or possibly intercept or corrupt AF_VSOCK messages destined to other clients.