CVE-2025-21088 Affecting mattermost-fips-10.7 package, versions <10.7.1-r1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.58% (48th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-MATTERMOSTFIPS107-9911053
  • published1 May 2025
  • disclosed15 Jan 2025

Introduced: 15 Jan 2025

CVE-2025-21088  (opens in a new tab)

How to fix?

Upgrade Chainguard mattermost-fips-10.7 to version 10.7.1-r1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mattermost-fips-10.7 package and not the mattermost-fips-10.7 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

Mattermost versions 10.2.x <= 10.2.0, 9.11.x <= 9.11.5, 10.0.x <= 10.0.3, 10.1.x <= 10.1.3 fail to properly validate the style of proto supplied to an action's style in post.props.attachments, which allows an attacker to crash the frontend via crafted malicious input.

CVSS Base Scores

version 3.1