Divide By Zero Affecting mods package, versions <1.8.1-r14


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.64% (50th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-MODS-17802405
  • published3 Jul 2026
  • disclosed20 Mar 2025

Introduced: 20 Mar 2025

CVE-2024-8063  (opens in a new tab)
CWE-369  (opens in a new tab)

How to fix?

Upgrade Chainguard mods to version 1.8.1-r14 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mods package and not the mods package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

A divide by zero vulnerability exists in ollama/ollama version v0.3.3. The vulnerability occurs when importing GGUF models with a crafted type for block_count in the Modelfile. This can lead to a denial of service (DoS) condition when the server processes the model, causing it to crash.

CVSS Base Scores

version 3.1