Divide By Zero Affecting mods package, versions <1.8.1-r14


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
14.5% (97th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-MODS-17802411
  • published3 Jul 2026
  • disclosed20 Mar 2025

Introduced: 20 Mar 2025

CVE-2025-0317  (opens in a new tab)
CWE-369  (opens in a new tab)

How to fix?

Upgrade Chainguard mods to version 1.8.1-r14 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mods package and not the mods package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

A vulnerability in ollama/ollama versions <=0.3.14 allows a malicious user to upload and create a customized GGUF model file on the Ollama server. This can lead to a division by zero error in the ggufPadding function, causing the server to crash and resulting in a Denial of Service (DoS) attack.

CVSS Base Scores

version 3.1