CVE-2025-70952 Affecting nextflow package, versions <25.10.4-r2


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.87% (59th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-NEXTFLOW-15986879
  • published12 Apr 2026
  • disclosed25 Mar 2026

Introduced: 25 Mar 2026

CVE-2025-70952  (opens in a new tab)

How to fix?

Upgrade Chainguard nextflow to version 25.10.4-r2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nextflow package and not the nextflow package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

pf4j before 20c2f80 has a path traversal vulnerability in the extract() function of Unzip.java, where improper handling of zip entry names can allow directory traversal or Zip Slip attacks, due to a lack of proper path normalization and validation.

CVSS Base Scores

version 3.1