CVE-2025-12819 Affecting pgbouncer package, versions <1.25.1-r0


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.36% (30th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-PGBOUNCER-14421682
  • published15 Dec 2025
  • disclosed3 Dec 2025

Introduced: 3 Dec 2025

CVE-2025-12819  (opens in a new tab)

How to fix?

Upgrade Chainguard pgbouncer to version 1.25.1-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pgbouncer package and not the pgbouncer package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

Untrusted search path in auth_query connection handler in PgBouncer before 1.25.1 allows an unauthenticated attacker to execute arbitrary SQL during authentication via a malicious search_path parameter in the StartupMessage.

CVSS Base Scores

version 3.1