CVE-2026-6666 Affecting pgbouncer package, versions <1.25.2-r0


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.37% (31st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-PGBOUNCER-16786518
  • published21 May 2026
  • disclosed9 May 2026

Introduced: 9 May 2026

CVE-2026-6666  (opens in a new tab)

How to fix?

Upgrade Chainguard pgbouncer to version 1.25.2-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pgbouncer package and not the pgbouncer package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

A possible null pointer reference in PgBouncer before 1.25.2 could lead to a crash, if a server sends an error response without SQLSTATE field.

CVSS Base Scores

version 3.1