Improper Authentication Affecting prometheus-pushgateway-fips-1.4 package, versions <1.4.3-r4


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.26% (69th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-PROMETHEUSPUSHGATEWAYFIPS14-6191717
  • published26 Jan 2024
  • disclosed29 Nov 2022

Introduced: 29 Nov 2022

CVE-2022-46146  (opens in a new tab)
CWE-287  (opens in a new tab)
CWE-303  (opens in a new tab)

How to fix?

Upgrade Chainguard prometheus-pushgateway-fips-1.4 to version 1.4.3-r4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream prometheus-pushgateway-fips-1.4 package and not the prometheus-pushgateway-fips-1.4 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

Prometheus Exporter Toolkit is a utility package to build exporters. Prior to versions 0.7.2 and 0.8.2, if someone has access to a Prometheus web.yml file and users' bcrypted passwords, they can bypass security by poisoning the built-in authentication cache. Versions 0.7.2 and 0.8.2 contain a fix for the issue. There is no workaround, but attacker must have access to the hashed password to use this functionality.

CVSS Base Scores

version 3.1