Deserialization of Untrusted Data Affecting py3.11-pytorch-cuda-11.8 package, versions <2.3.1-r11


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.37% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-PY311PYTORCHCUDA118-15993291
  • published12 Apr 2026
  • disclosed18 Apr 2025

Introduced: 18 Apr 2025

CVE-2025-32434  (opens in a new tab)
CWE-502  (opens in a new tab)

How to fix?

Upgrade Chainguard py3.11-pytorch-cuda-11.8 to version 2.3.1-r11 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream py3.11-pytorch-cuda-11.8 package and not the py3.11-pytorch-cuda-11.8 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

PyTorch is a Python package that provides tensor computation with strong GPU acceleration and deep neural networks built on a tape-based autograd system. In version 2.5.1 and prior, a Remote Command Execution (RCE) vulnerability exists in PyTorch when loading a model using torch.load with weights_only=True. This issue has been patched in version 2.6.0.

CVSS Base Scores

version 3.1