Improper Handling of Highly Compressed Data (Data Amplification) Affecting py3-pillow package, versions <13.0.0-r0


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.5% (43rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-PY3PILLOW-21663644
  • published24 Oct 2026
  • disclosed19 Oct 2026

Introduced: 19 Oct 2026

NewCVE-2026-112892  (opens in a new tab)
CWE-409  (opens in a new tab)

How to fix?

Upgrade Chainguard py3-pillow to version 13.0.0-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream py3-pillow package and not the py3-pillow package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

Pillow is a Python imaging library. From 4.1.0 until 13.0.0, Pillow's MSP RLE decoder can expand a small file into an unbounded in-memory buffer. The decoder writes run-length output to BytesIO without limiting expansion to the declared image size. An attacker can supply a crafted MSP image to an application that loads its pixels. This can exhaust memory and deny service even when the declared pixel count passes the decompression-bomb check. This issue is fixed in version 13.0.0.

CVSS Base Scores

version 3.1