OS Command Injection Affecting py3-pytorch-cuda-13.0 package, versions <2.14.1-r2


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.3% (71st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-PY3PYTORCHCUDA130-21693705
  • published24 Oct 2026
  • disclosed19 Oct 2026

Introduced: 19 Oct 2026

NewCVE-2026-112900  (opens in a new tab)
CWE-78  (opens in a new tab)
CWE-88  (opens in a new tab)

How to fix?

Upgrade Chainguard py3-pytorch-cuda-13.0 to version 2.14.1-r2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream py3-pytorch-cuda-13.0 package and not the py3-pytorch-cuda-13.0 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

Pillow is a Python imaging library. From 2.6.0 until 13.0.0, Pillow is vulnerable to argument injection when invoking Ghostscript for EPS input. EpsImagePlugin.Ghostscript passes a caller-controlled input filename after -f without converting it to a safe absolute path, so a name beginning with a hyphen can be interpreted as a Ghostscript option. An attacker who controls the filename can inject Ghostscript arguments. Arbitrary command execution specifically requires a leading @ argument-file filename and control of the referenced text file containing additional Ghostscript arguments; the reported chain reproduces with the default -dSAFER invocation. This issue is fixed in version 13.0.0.

CVSS Base Scores

version 3.1