Use of Externally-Controlled Format String Affecting ruby4.0-fluentd-kubernetes-daemonset-1.16 package, versions <1.16.11.1.0-r2


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.87% (59th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-RUBY40FLUENTDKUBERNETESDAEMONSET116-17372963
  • published18 Jun 2026
  • disclosed20 Mar 2026

Introduced: 20 Mar 2026

CVE-2026-33210  (opens in a new tab)
CWE-134  (opens in a new tab)

How to fix?

Upgrade Chainguard ruby4.0-fluentd-kubernetes-daemonset-1.16 to version 1.16.11.1.0-r2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby4.0-fluentd-kubernetes-daemonset-1.16 package and not the ruby4.0-fluentd-kubernetes-daemonset-1.16 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

Ruby JSON is a JSON implementation for Ruby. From version 2.14.0 to before versions 2.15.2.1, 2.17.1.2, and 2.19.2, a format string injection vulnerability can lead to denial of service attacks or information disclosure, when the allow_duplicate_key: false parsing option is used to parse user supplied documents. This issue has been patched in versions 2.15.2.1, 2.17.1.2, and 2.19.2.

CVSS Base Scores

version 3.1