Deserialization of Untrusted Data Affecting spark-3.5 package, versions <3.5.7-r2


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.41% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-SPARK35-15993439
  • published12 Apr 2026
  • disclosed2 Oct 2022

Introduced: 2 Oct 2022

CVE-2022-42003  (opens in a new tab)
CWE-502  (opens in a new tab)

How to fix?

Upgrade Chainguard spark-3.5 to version 3.5.7-r2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream spark-3.5 package and not the spark-3.5 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

In FasterXML jackson-databind before versions 2.13.4.1 and 2.12.17.1, resource exhaustion can occur because of a lack of a check in primitive value deserializers to avoid deep wrapper array nesting, when the UNWRAP_SINGLE_VALUE_ARRAYS feature is enabled.

CVSS Base Scores

version 3.1