Improper Authorization Affecting superset-4.1 package, versions <4.1.4-r3


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.6% (48th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-SUPERSET41-15993470
  • published12 Apr 2026
  • disclosed14 Aug 2025

Introduced: 14 Aug 2025

CVE-2025-55675  (opens in a new tab)
CWE-285  (opens in a new tab)

How to fix?

Upgrade Chainguard superset-4.1 to version 4.1.4-r3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream superset-4.1 package and not the superset-4.1 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

Apache Superset contains an improper access control vulnerability in its /explore endpoint. A missing authorization check allows an authenticated user to discover metadata about datasources they do not have permission to access. By iterating through the datasource_id in the URL, an attacker can enumerate and confirm the existence and names of protected datasources, leading to sensitive information disclosure.

This issue affects Apache Superset: before 5.0.0.

Users are recommended to upgrade to version 5.0.0, which fixes the issue.

CVSS Base Scores

version 3.1