Incorrect Type Conversion or Cast Affecting tensorflow-gpu-jupyter package, versions <2.21.0-r12


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.64% (49th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-TENSORFLOWGPUJUPYTER-20562525
  • published7 Oct 2026
  • disclosed8 Jul 2026

Introduced: 8 Jul 2026

CVE-2026-59871  (opens in a new tab)
CWE-704  (opens in a new tab)

How to fix?

Upgrade Chainguard tensorflow-gpu-jupyter to version 2.21.0-r12 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tensorflow-gpu-jupyter package and not the tensorflow-gpu-jupyter package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

node-tar is a tar archive manipulation library for Node.js. Prior to 7.5.18, node-tar coerces all-digit PAX path and linkpath values in src/pax.ts to JavaScript numbers, causing downstream path handling such as normalizeWindowsPath(entry.path).split('/') to throw an uncaught TypeError. This issue is fixed in version 7.5.18.

CVSS Base Scores

version 3.1