Directory Traversal Affecting tensorflow-gpu-jupyter package, versions <2.21.0-r12


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.45% (38th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-TENSORFLOWGPUJUPYTER-20562564
  • published7 Oct 2026
  • disclosed3 Aug 2026

Introduced: 3 Aug 2026

CVE-2026-69153  (opens in a new tab)
CWE-22  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade Chainguard tensorflow-gpu-jupyter to version 2.21.0-r12 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tensorflow-gpu-jupyter package and not the tensorflow-gpu-jupyter package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

PostCSS takes a CSS file and provides an API to analyze and modify its rules by transforming the rules into an Abstract Syntax Tree. Prior to 8.5.19, if from is unset, an attacker can cause PreviousMap.loadFile() to read an unintended source-map file by supplying an absolute or directory-traversal sourceMappingURL. The resulting map’s sources and sourcesContent may then be exposed to the application. This issue is fixed in version 8.5.19.

CVSS Base Scores

version 3.1