Use of Uninitialized Resource Affecting tensorflow-gpu-jupyter package, versions <2.21.0-r12


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.75% (55th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-TENSORFLOWGPUJUPYTER-20562607
  • published7 Oct 2026
  • disclosed15 May 2026

Introduced: 15 May 2026

CVE-2026-45736  (opens in a new tab)
CWE-908  (opens in a new tab)

How to fix?

Upgrade Chainguard tensorflow-gpu-jupyter to version 2.21.0-r12 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tensorflow-gpu-jupyter package and not the tensorflow-gpu-jupyter package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

ws is an open source WebSocket client and server for Node.js. Prior to 8.20.1, the websocket.close() implementation is vulnerable to uninitialized memory disclosure when a TypedArray is passed as the reason argument. This vulnerability is fixed in 8.20.1.

References

CVSS Base Scores

version 3.1