CVE-2025-0377 Affecting terraform package, versions <1.5.7-r36


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.68% (53rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-TERRAFORM-8658637
  • published22 Jan 2025
  • disclosed21 Jan 2025

Introduced: 21 Jan 2025

CVE-2025-0377  (opens in a new tab)

How to fix?

Upgrade Chainguard terraform to version 1.5.7-r36 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream terraform package and not the terraform package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

HashiCorp’s go-slug library is vulnerable to a zip-slip style attack when a non-existing user-provided path is extracted from the tar entry.

CVSS Base Scores

version 3.1