Incorrect Authorization Affecting terraform-1.11 package, versions <1.11.2-r1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.95% (57th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-TERRAFORM111-9509291
  • published21 Mar 2025
  • disclosed20 Jul 2021

Introduced: 20 Jul 2021

CVE-2021-36230  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade Chainguard terraform-1.11 to version 1.11.2-r1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream terraform-1.11 package and not the terraform-1.11 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

HashiCorp Terraform Enterprise releases up to v202106-1 did not properly perform authorization checks on a subset of API requests executed using the run token, allowing privilege escalation to organization owner. Fixed in v202107-1.

CVSS Base Scores

version 3.1