Improper Validation of Array Index Affecting tritonserver-backend-vllm-cuda-12.9 package, versions <25.9.0_git20251112-r1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.41% (35th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-TRITONSERVERBACKENDVLLMCUDA129-14156323
  • published2 Dec 2025
  • disclosed21 Nov 2025

Introduced: 21 Nov 2025

CVE-2025-62372  (opens in a new tab)
CWE-129  (opens in a new tab)

How to fix?

Upgrade Chainguard tritonserver-backend-vllm-cuda-12.9 to version 25.9.0_git20251112-r1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tritonserver-backend-vllm-cuda-12.9 package and not the tritonserver-backend-vllm-cuda-12.9 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

vLLM is an inference and serving engine for large language models (LLMs). From version 0.5.5 to before 0.11.1, users can crash the vLLM engine serving multimodal models by passing multimodal embedding inputs with correct ndim but incorrect shape (e.g. hidden dimension is wrong), regardless of whether the model is intended to support such inputs (as defined in the Supported Models page). This issue has been patched in version 0.11.1.

CVSS Base Scores

version 3.1