CVE-2025-6013 Affecting vault-1.17 package, versions <1.17.6-r23


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.53% (45th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-VAULT117-15993616
  • published12 Apr 2026
  • disclosed6 Aug 2025

Introduced: 6 Aug 2025

CVE-2025-6013  (opens in a new tab)

How to fix?

Upgrade Chainguard vault-1.17 to version 1.17.6-r23 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream vault-1.17 package and not the vault-1.17 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

Vault and Vault Enterprise’s (“Vault”) ldap auth method may not have correctly enforced MFA if username_as_alias was set to true and a user had multiple CNs that are equal but with leading or trailing spaces. Fixed in Vault Community Edition 1.20.2 and Vault Enterprise 1.20.2, 1.19.8, 1.18.13, and 1.16.24.

CVSS Base Scores

version 3.1