Reachable Assertion Affecting vllm-openai-cuda-12.9 package, versions <0.28.0-r0


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.67% (50th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-VLLMOPENAICUDA129-19537939
  • published5 Sept 2026
  • disclosed6 Jul 2026

Introduced: 6 Jul 2026

CVE-2026-55514  (opens in a new tab)
CWE-617  (opens in a new tab)

How to fix?

Upgrade Chainguard vllm-openai-cuda-12.9 to version 0.28.0-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream vllm-openai-cuda-12.9 package and not the vllm-openai-cuda-12.9 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

vLLM is a library for LLM inference and serving. From 0.12.0 to before 0.24.0, sending a pure prompt embeds payload in a /v1/completions request with a model using M-RoPE causes EngineCore to fail an assertion and fatally crash, shutting down the entire server application. Any remote user who is authorized to make a /v1/completions request can make such a request and induce a crash. This issue is fixed in version 0.24.0.

CVSS Base Scores

version 3.1