Improper Input Validation Affecting cordova Open this link in a new tab package, versions <3.3.0


0.0
high
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-CORDOVA-470721

  • published

    2 Oct 2019

  • disclosed

    2 Mar 2014

  • credit

    Unknown

How to fix?

Upgrade Cordova to version 3.3.0 or higher.

Overview

Cordova is a CocoaPods package for Cordova iOS

Affected versions of this package are vulnerable to Improper Input Validation. It is possible to bypass whitelist protection mechanism within Cordova due to missing validations. The vulnerability is possible because it does not anchor the end of domain-name regular expressions. Therefore, it allows attacker to bypass the protection by using a domain name that has an acceptable name as an initial substring.