Access Restriction Bypass Affecting cordova package, versions >=2.0.0, <3.4.0


0.0
high
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-CORDOVA-470776

  • published

    2 Oct 2019

  • disclosed

    2 Mar 2014

  • credit

    Unknown

How to fix?

Upgrade Cordova to version 3.4.0 or higher.

Overview

Cordova is a CocoaPods package for Cordova iOS

Affected versions of this package are vulnerable to Access Restriction Bypass. Leveraging on an event-based bridge, a library clone, and an IFRAME script execution, a remote attacker is able to directly access bridge JavaScript objects as demonstrated by certain cordova.require calls.