Buffer Overflow Affecting ffmpeg Open this link in a new tab package, versions >=2.2, <2.8.3


0.0
high
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-FFMPEG-470701

  • published

    2 Oct 2019

  • disclosed

    4 Oct 2014

  • credit

    Unknown

How to fix?

Upgrade FFmpeg to version 2.8.3 or higher.

Overview

FFmpeg is a FFmpeg static library ruby binding that is compiled for iOS and CocoaPods.

Affected versions of this package are vulnerable to Buffer Overflow. These attacks are possible because of an off-by-one error in smc.c leads to out-of-bounds access through the use of Quicktime Graphics video data.