Buffer Overflow Affecting ffmpeg package, versions >=2.2, <2.8.3


0.0
high
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-FFMPEG-470702

  • published

    2 Oct 2019

  • disclosed

    27 Nov 2014

  • credit

    Unknown

How to fix?

Upgrade FFmpeg to version 2.8.3 or higher.

Overview

FFmpeg is a FFmpeg static library ruby binding that is compiled for iOS and CocoaPods.

Affected versions of this package are vulnerable to Buffer Overflow. These attacks are possible because the raw_decode function allows remote attackers to cause an out-of-bounds heap access. The attacks can be performed through a .cine file that triggers the avpicture_get_size to return a negative frame size.