Out-of-bounds Write Affecting ffmpeg Open this link in a new tab package, versions >=2.2, <2.8.3


0.0
critical
  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-FFMPEG-470708

  • published

    2 Oct 2019

  • disclosed

    23 Jan 2017

  • credit

    Unknown

How to fix?

Upgrade FFmpeg to version 2.8.3 or higher.

Overview

FFmpeg is a FFmpeg static library ruby binding that is compiled for iOS and CocoaPods.

Affected versions of this package are vulnerable to Out-of-bounds Write. The vulnerability is caused by an off-by-one error which creates an out-of-bound write through the decode_zbuf function in libavcodec/pngdec.c.