Numeric Errors Affecting ffmpeg package, versions >=2.2, <2.8.3


0.0
high

Snyk CVSS

    Attack Complexity Low
NVD  high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-COCOAPODS-FFMPEG-470716
  • published 2 Oct 2019
  • disclosed 5 Oct 2014
  • credit Unknown

How to fix?

Upgrade FFmpeg to version 2.8.3 or higher.

Overview

FFmpeg is a FFmpeg static library ruby binding that is compiled for iOS and CocoaPods.

Affected versions of this package are vulnerable to Numeric Errors because on2avc.c does not restrict the number of channels to 2 or less.